Wallet Passphrase has a bug!?

I could not open import my wallet with the json file and my passphrase, the app doesen’t recognise my passphrase anymore.
→ First I thought I accidentally modified my passphrase, but now I encountered another similar problem: I tried to create a new wallet and followed the passphrase instruction, I entered this: Ghee46M? which technically fulfils the requirements and it doesen’t work as well.

Is there a bug/problem with the wallet? and can someone of the team help me with this issue?

Tried on Safari/chrome on a macbook.

? is not a valid character, the copy is wrong. This was supposed to be updated before release but must have slipped through the cracks.

Use a different password and you will be able to create the wallet without issues. Besides, this password is now doxxed :wink:

Ok great, but my original Passphrase of my existing wallet also contains a “?” - that’s probably why I can’t access my wallet anymore?

How can I get my wallet back?

Looking forward to further progress.

Is there any update on this? I am still locked out of my wallet.

Hey @samwithacoin I ran into the same issue. I ended up chaning my passphrase. If you have access to a Pocket Node you can use the CLI and the pocket accounts update-passphrase <address> to change the passphrase for an account. Details are here Accounts Namespace - Pocket Core - if you can’t wait for the wallet to be fixed. Hope that helps.

Thank you very much for the input Steve, good to know access can be restored.

However I’m not technically capable to do this - can the wallet be fixed by the tech team?

From what I understand the private key can be used in this case. It will ask you for a temp passphrase on a session by session basis.

While we are on the topic, can anyone tell me what the public key is used for?

The string under the public address is what I am referring to.

And also, why does this key include the second half of the private key?

The second half of your private key is your public key because of how Pocket generates it’s wallets.

The public key is used for actually signing and verifying transactions.

1 Like

Correct, but for some odd reason I did not extract the private key for this wallet because I thought Passphrase + JSON file is enough for the moment. So still sitting in the dark on how to resolve this.

Or is it possible to extract the private key from my JSON with the passphrase?

We’re working on a fix for this as we speak. Would you mind reaching out to me directly so I can collect some more details about your system/what problem you’ve experienced.

If anyone is experiencing issues where they cannot import their key file, try to import the key file through Incognito/Private browsing mode.