Polygon Public RPC - cannot connect with Metamask


This is probably a problem local to my machine, but I am unable to get to the bottom of the issue.

I am using the public rpc docs to set up metamask for the pocket network public RPCs. It has worked for Ethereum (web and ios App) and also for Polygon within the Metamask IOS App.
However, when I try to add the Polygon Pocket Portal to the web browser plugin using the RPC endpoint https://poly-rpc.gateway.pokt.network/ as described in the docs and in the video tutorial, the connection unfortunately fails.

In the JS Console, an error appears:

Unknown Infura provider type “https://poly-rpc.gateway.pokt.network/

I have tried in Chrome as well with the same result.
OS: Win 11, 64-bit
Firefox 98.0.1
Metamask: 10.11.1

Again, the conection works in the Metamask IOS app. Has anyone else experienced this problem, or does anyone have any suggestions?
Thanks in advance,

I’ve had issues with polygon as well recently. First thing I would check is make sure chrome and metamask are updated to newest version. If using hardware wallet, make sure that the firmware is updated as well.

The second option is to delete any time other chainID with 137, so remove any other custom polygon RPC.

Lastly, in chrome url type chrome:restart which closes and refreshes all tabs open. It’ll make you log back into metamask.

These are the things I do when I’m having MM issues. Simple but usually resolves my issues.

Thanks for your reply. I was on holiday for the last 2 weeks and the RPC Endpoint is working now. If I have any more problems, I will definitely try your suggestions - or simply go on holiday again :slight_smile: